Menu

2/3/19

Open Port (Port Forwarding) trong Router cisco

Có rất nhiều dịch vụ trong mạng Lan khi triển khai hệ thống, nhà quảng trị cần Openport ra ngoài để tiện cho việc bảo trì, nâng cấp hệ thống như Remote Desktop Connection, SSH, Web server, FTP....

Xây dựng đồ hình sau:


Trên router Web,


hostname Web
!

!
interface FastEthernet0/1
 ip address 172.16.18.3 255.255.255.0

 duplex auto
 speed auto
!

ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.16.18.1
!
!
ip http server //gia lap web server

Trên router SSH



hostname SSH
!

!
enable password enablepass
!

ip domain name dotech.vn  //muc dich dung te tao key rsa

!
!
username cisco password 0 123456 //thong tin chung thuc ssh
!

ip ssh version 2
!
!
!
!
!
interface FastEthernet0/0
 ip address 172.16.18.2 255.255.255.0


!

ip route 0.0.0.0 0.0.0.0 172.16.18.1
!
!
line vty 0 4  //5 phien ket noi cung 1 luc
 login local
 transport input ssh

!

Trên router NAT


hostname NAT
!
!
!
interface FastEthernet0/0
 ip address 10.10.10.1 255.255.255.252

 ip nat outside


!
interface FastEthernet1/0
 ip address 172.16.18.1 255.255.255.0

 ip nat inside


!
!

ip nat inside source static tcp 172.16.18.2 22 10.10.10.1 22 // openport dich vu ssh
ip nat inside source static tcp 172.16.18.3 80 10.10.10.1 8080 //openport dich vu web

!

Trên Router Remote 



hostname Remote
!

!
!
!
interface FastEthernet0/0
 ip address 10.10.10.2 255.255.255.252

 !

!

Tiến hành kiểm tra kết quả,

-Dịch vụ web,

Remote#telnet 10.10.10.1 8080
Trying 10.10.10.1, 8080 ... Open


Phiên kết nối phía client hiện thị như sau,


Web#sh ip http server connection

HTTP server current connections:
local-ipaddress:port  remote-ipaddress:port in-bytes   out-bytes
    172.16.18.3:80         10.10.10.2:56152 6          0


-Dịch vụ SSH,


 Remote#ssh -l cisco 10.10.10.1
Password:

SSH>en
Password:
SSH#





 


No comments:

Post a Comment